summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2015-12-07 16:18:35 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-02-02 09:23:00 -0500
commit2b2f2fc1797c3a5d8398307205365667ce5941db (patch)
tree33077b78e80a88618b24385018426d84619c8731 /gnu/packages/python.scm
parentce294c0445aa7c6472bc02d9f83d1171b8d88e77 (diff)
gnu: Add python-colorama.
* gnu/packages/python.scm (python-colorama, python2-colorama): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 433fe3ceaf..247d3c5b5e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
@@ -7250,3 +7250,26 @@ supports url redirection and retries, and also gzip and deflate decoding.")
(define-public python2-urllib3
(package-with-python2 python-urllib3))
+
+(define-public python-colorama
+ (package
+ (name "python-colorama")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "colorama" version))
+ (sha256
+ (base32
+ "1716z9pq1r5ys3nkg7wdrb3h2f9rmd0zdxpxzmx3bgwgf6xg48gb"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (synopsis "colored terminal text rendering for Python")
+ (description "Colorama is a Python library for rendering colored terminal
+text.")
+ (home-page "https://pypi.python.org/pypi/colorama")
+ (license bsd-3)))
+
+(define-public python2-colorama
+ (package-with-python2 python-colorama))