summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-12 03:24:12 -0400
committerMark H Weaver <mhw@netris.org>2015-06-13 23:01:07 -0400
commit4c50e5ab3a393c6d86fc6362c58f7ecf32dd9680 (patch)
tree1251c98b95b58326788e67c7e6f63bb2984e7f8f /gnu/packages/python.scm
parent8c01b9d05aa5d5449398d5babdf7fa1fe95af1c2 (diff)
gnu: python: Disable ssl test that fails with openssl-1.0.2b.
* gnu/packages/patches/python-disable-ssl-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/python.scm (python): Add patch.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 914c2dc23c..232a785778 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -207,7 +207,9 @@ data types.")
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
- (patches (list (search-patch "python-fix-tests.patch")))
+ (patches (list (search-patch "python-fix-tests.patch")
+ ;; XXX Try removing this patch for python > 3.4.3
+ (search-patch "python-disable-ssl-test.patch")))
(patch-flags '("-p0"))
(sha256
(base32