summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-25 21:15:13 -0500
committerMark H Weaver <mhw@netris.org>2015-01-25 21:15:13 -0500
commit5ade90ba6976a5ce8715de07344985c70c0eda8b (patch)
tree7d42618d87ebd8888223e2aa1d0cd5375b3a7712 /gnu/packages/python.scm
parent06aac933e1cc97781db0d28eb86b5d984099a30e (diff)
parent94987ebe136569dfe0180277384d7c04e18ab78c (diff)
Merge branch 'wip-gobject-introspection'
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 5 insertions, 28 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5555acfbfa..4b306952c1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2170,13 +2170,6 @@ that client code uses to construct the grammar directly in Python code.")
;; at run-time the user must set this variable as follows:
;;
;; export GI_TYPELIB_PATH=~/.guix-profile/lib/girepository-1.0
- ;;
- ;; 'typelib' files include references to dynamic libraries. Currently
- ;; the references do not include the full path to the libraries. For
- ;; this reason the user must set the LD_LIBRARY_PATH to the location of
- ;; 'libgtk-3.so.0', 'libgdk-3.so.0' and 'libatk-1.0.so.0':
- ;;
- ;; export LD_LIBRARY_PATH=~/.guix-profile/lib
("gtk+" ,gtk+)
;; From version 1.4.0 'matplotlib' makes use of 'cairocffi' instead of
;; 'pycairo'. However, 'pygobject' makes use of a 'pycairo' 'context'
@@ -2199,7 +2192,7 @@ that client code uses to construct the grammar directly in Python code.")
("freetype" ,freetype)
("cairo" ,cairo)
("glib" ,glib)
- ("python-pillow" ,python-pillow)
+ ;("python-pillow" ,python-pillow)
;; FIXME: Add backends when available.
;("python-wxpython" ,python-wxpython)
;("python-pyqt" ,python-pyqt)
@@ -2217,10 +2210,6 @@ that client code uses to construct the grammar directly in Python code.")
(gtk+ (assoc-ref inputs "gtk+")))
;; Setting these directories in the 'basedirlist' of 'setup.cfg'
;; has not effect.
- ;;
- ;; FIXME: setting LD_LIBRARY_PATH should be removed once we patch
- ;; gobject-introspection to include the full path of shared
- ;; libraries in 'typelib' files.
(setenv "LD_LIBRARY_PATH"
(string-append cairo "/lib:" gtk+ "/lib"))
(setenv "HOME" (getcwd))
@@ -2282,30 +2271,18 @@ toolkits.")
,@(alist-delete "python-numpydoc"
(package-inputs matplotlib)))))))
-;; Scipy 0.14.0 with Numpy 0.19.X fails several tests. This is known and
-;; planned to be fixed in 0.14.1. It is claimed that the failures can safely
-;; be ignored:
-;; http://mail.scipy.org/pipermail/scipy-dev/2014-September/020043.html
-;; https://github.com/scipy/scipy/issues/3853
-;;
-;; The main test suite procedure prints the summary message:
-;;
-;; Ran 16412 tests in 245.033s
-;; FAILED (KNOWNFAIL=277, SKIP=921, errors=327, failures=42)
-;;
-;; However, it still does return normally.
(define-public python-scipy
(package
(name "python-scipy")
- (version "0.14.0")
+ (version "0.15.0")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/scipy"
- "/scipy-" version ".tar.gz"))
+ "/scipy-" version ".tar.xz"))
(sha256
(base32
- "053bmz4qmnk4dmxvspfak8r10rpmy6mzwfzgy33z338ppzka6hab"))))
+ "0fsqi05s035d7p6s8h3h2pvk1axias16chy17rw9l1bxvrfhmncf"))))
(build-system python-build-system)
(inputs
`(("python-numpy" ,python-numpy)