summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-29 22:54:43 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-30 00:05:13 +0300
commit7dd55dfecad00cadb91e6efe09a442cdfc51798d (patch)
treeb7a2f1a136ed5dccfdf3d99606007c7ebb20bf9b /gnu/packages/python.scm
parent603d55de4ab14f7e410cec7a215982ac2430cc58 (diff)
gnu: python-waf: Update to 1.9.5.
* gnu/packages/python.scm (python-waf): Update to 1.9.5. [arguments]: Shorten custom build phase. [source]: Use http. [home-page]: Use http.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f7485ad014..45e683c009 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5236,30 +5236,28 @@ connection to each user.")
(define-public python-waf
(package
(name "python-waf")
- (version "1.9.1")
+ (version "1.9.5")
(source (origin
(method url-fetch)
- (uri (string-append "https://waf.io/"
+ (uri (string-append "http://waf.io/"
"waf-" version ".tar.bz2"))
(sha256
(base32
- "1nc4qaqx2vsanlpp9mcwvf91xjqpkvcc6fcxd5sb4fwvaxamw5v6"))))
+ "1sl3ipi2czds57rlzjnpdzqa0skx8asfvmh3qmibpvdwf15rpppg"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(replace 'build
- (lambda _
- (zero? (begin
- (system* "python" "waf-light" "configure")
- (system* "python" "waf-light" "build")))))
+ (lambda _
+ (zero? (system* "python" "waf-light" "configure" "build"))))
(replace 'check
- (lambda _
- (zero? (system* "python" "waf" "--version"))))
+ (lambda _
+ (zero? (system* "python" "waf" "--version"))))
(replace 'install
- (lambda _
- (copy-file "waf" %output))))))
- (home-page "https://waf.io/")
+ (lambda _
+ (copy-file "waf" %output))))))
+ (home-page "http://waf.io/")
(synopsis "Python-based build system")
(description
"Waf is a Python-based framework for configuring, compiling and installing