summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-01-02 08:25:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-01-02 08:37:21 +0100
commit819939cb94c5aaad85984695d651c3c36d9dd6e3 (patch)
tree91712f00446c4c763a967cfd12966852019d7008 /gnu/packages/python.scm
parent5043b20dcdff6ddbeffd59dbaa890929874e19fd (diff)
gnu: python-pycparser: Use ‘modify-phases’ syntax.
* gnu/packages/python.scm (python-pycparser)[arguments]: Use ‘modify-phases’.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm36
1 files changed, 17 insertions, 19 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 88f74a3b73..59400a3d23 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -32,7 +32,7 @@
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;;
;;; This file is part of GNU Guix.
@@ -4280,24 +4280,22 @@ a general image processing tool.")
`(("pkg-config" ,pkg-config)))
(arguments
`(#:phases
- (alist-replace
- 'check
- (lambda _
- (with-directory-excursion "tests"
- (zero? (system* "python" "all_tests.py"))))
- (alist-cons-after
- 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((data (string-append (assoc-ref outputs "doc") "/share"))
- (doc (string-append data "/doc/" ,name "-" ,version))
- (examples (string-append doc "/examples")))
- (mkdir-p examples)
- (for-each (lambda (file)
- (copy-file (string-append "." file)
- (string-append doc file)))
- '("/README.rst" "/CHANGES" "/LICENSE"))
- (copy-recursively "examples" examples)))
- %standard-phases))))
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "tests"
+ (zero? (system* "python" "all_tests.py")))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((data (string-append (assoc-ref outputs "doc") "/share"))
+ (doc (string-append data "/doc/" ,name "-" ,version))
+ (examples (string-append doc "/examples")))
+ (mkdir-p examples)
+ (for-each (lambda (file)
+ (copy-file (string-append "." file)
+ (string-append doc file)))
+ '("/README.rst" "/CHANGES" "/LICENSE"))
+ (copy-recursively "examples" examples)))))))
(home-page "https://github.com/eliben/pycparser")
(synopsis "C parser in Python")
(description