summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 15:59:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 16:50:26 +0200
commit035989c403252f22015e363124bdc82a1116907f (patch)
treecbe959929e6d3a93eb092524f3d15f44c486e426 /gnu/packages/python.scm
parentc27a9d8a880a07a3c108dac85d84d38bf287b2be (diff)
gnu: Add python-partd.
* gnu/packages/python.scm (python-partd): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 97b4ca86cd..b771452629 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14221,3 +14221,28 @@ regular-spaced values, etc.
This Python package wraps the Blosc library.")
(license license:bsd-3)))
+
+(define-public python-partd
+ (package
+ (name "python-partd")
+ (version "0.3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "partd" version))
+ (sha256
+ (base32
+ "03s0i5qfgkx6y24bmfgyd5hnsjznkbbfafwb2khf7k9790f1yab7"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-blosc" ,python-blosc)
+ ("python-locket" ,python-locket)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-pyzmq" ,python-pyzmq)
+ ("python-toolz" ,python-toolz)))
+ (home-page "https://github.com/dask/partd/")
+ (synopsis "Appendable key-value storage")
+ (description "Partd stores key-value pairs. Values are raw bytes. We
+append on old values. Partd excels at shuffling operations.")
+ (license license:bsd-3)))