summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-10 16:32:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-10 20:27:42 +0200
commit418ec0adc9ee8096683064f1aa0c486a8788e1ca (patch)
treef3c29b2c53548eabee08312d2ccac81a5c3e9acb /gnu/packages/python.scm
parentba0052e8ae3c36bf016f539ced2d889a78ba13e5 (diff)
gnu: python-libarchive-c: Update to 2.8.
* gnu/packages/python.scm (python-libarchive-c): Update to 2.8. [arguments]: Replace 'check' phase. [native-inputs]: Add PYTHON-MOCK and PYTHON-PYTEST.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ce5db2f0e2..a8378bf360 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6624,13 +6624,13 @@ a hash value.")
(define-public python-libarchive-c
(package
(name "python-libarchive-c")
- (version "2.2")
+ (version "2.8")
(source (origin
(method url-fetch)
(uri (pypi-uri "libarchive-c" version))
(sha256
(base32
- "0z4r7v3dhd6b3120mav05ff08srih176r2rg5k8kn7mjd9pslm2x"))))
+ "0qg0v1s9c1xdk9philhnv8k6c6nicvnvfwlc0j9srg90jmdlvm06"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -6642,7 +6642,12 @@ a hash value.")
(substitute* "libarchive/ffi.py"
(("find_library\\('archive'\\)")
(string-append "'" libarchive
- "/lib/libarchive.so'")))))))))
+ "/lib/libarchive.so'"))))))
+ (replace 'check
+ (lambda _ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
(inputs
`(("libarchive" ,libarchive)))
(home-page "https://github.com/Changaco/python-libarchive-c")