summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-10 21:48:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-10 22:15:19 +0200
commitcc12ac58a2cab7937e230db0db95c80919969f11 (patch)
tree64297951cfe51a969796f4c09ba5f4b736de2db9 /gnu/packages/python.scm
parent7a6eaf5ca9c12c2d844223080694b94953abf982 (diff)
gnu: python-jedi: Update to 0.12.1.
* gnu/packages/python.scm (python-jedi): Update to 0.12.1. [synopsis, description]: Adjust to expanded functionality.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8d36883593..d1a912c15b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9639,14 +9639,14 @@ characters, mouse support, and auto suggestions.")
(define-public python-jedi
(package
(name "python-jedi")
- (version "0.12.0")
+ (version "0.12.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jedi" version))
(sha256
(base32
- "1bcr7csx4xil1iwmk03d79jis0bkmgi9k0kir3xa4rmwqsagcwhr"))))
+ "1h8ypnjisn57kiv1zqrkj1im6sbfnhxllqaa8znh39qkd47ys2dl"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -9658,11 +9658,14 @@ characters, mouse support, and auto suggestions.")
("python-parso" ,python-parso)
("python-docopt" ,python-docopt)))
(home-page "https://github.com/davidhalter/jedi")
- (synopsis
- "Autocompletion for Python that can be used for text editors")
+ (synopsis "Autocompletion and static analysis library for Python")
(description
- "Jedi is an autocompletion tool for Python that can be used for text
- editors.")
+ "Jedi is a static analysis tool for Python that can be used in Integrated
+Development Environments (@dfn{IDE}s) and text editors. It understands Python
+on a deeper level than many other static analysis frameworks for Python.
+
+Jedi understands docstrings and you can use Jedi autocompletion in your REPL as
+well.")
(license license:expat)))
(define-public python2-jedi