summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-11-04 02:44:00 +1100
committerMarius Bakke <mbakke@fastmail.com>2017-11-05 17:24:01 +0100
commit2e15906c1c1337945b6578c7f58a4fd4af52aaf3 (patch)
tree68b9db40405359bdbe97f009ecec2e39d0981e2f /gnu/packages/python.scm
parent7ed93a6c9eed5020b3ebd8abfbc59a6ec26fbc99 (diff)
gnu: Add python-dukpy, python2-dukpy.
gnu/packages/python.scm (python-dukpy, python2-dukpy): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e8a7339199..62446052ff 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
+;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16871,3 +16872,28 @@ executed more than a given number of times during a given period.")
(define-public python2-ratelimiter
(package-with-python2 python-ratelimiter))
+
+(define-public python-dukpy
+ (package
+ (name "python-dukpy")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/kovidgoyal/dukpy/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0pj39rfwlzivqm5hkrsza7gssg6ggpxlq5ivc8f3h7x5pfgc6y6c"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/kovidgoyal/dukpy")
+ (synopsis "Run JavaScript in python")
+ (description
+ "dukpy is a JavaScript runtime environment for Python using the duktape
+embeddable JavaScript engine.")
+ ;; Dukpy is licensed under MIT like the embedded duktape library,
+ ;; with 'errors.c' as GPL3.
+ (license (list license:expat license:gpl3))))
+
+(define-public python2-dukpy
+ (package-with-python2 python-dukpy))