summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2017-11-06 12:15:32 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-07 21:17:20 +0100
commit75d342ffa9a65177a711cac645df7ac569fe9609 (patch)
treeca9d57608400ac63d1c5440e23057d04f0590b2f /gnu/packages/python.scm
parent2b295f5a2fc221020dd4ae8e090bd19a7e017872 (diff)
gnu: Add python-networkx2.
* gnu/packages/python.scm (python-networkx2, python2-networkx2): New variables. * gnu/local.mk (dist_patch_DATA): Register 'python-networkx2-reproducible-build.patch'. * gnu/packages/patches/python-networkx2-reproducible-build.patch: New file. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5b11a6371c..370c9ef112 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6624,6 +6624,25 @@ of the structure, dynamics, and functions of complex networks.")
(define-public python2-networkx
(package-with-python2 python-networkx))
+;; Define new package, because the current version of python-colormath does
+;; not build against 2.0.
+(define-public python-networkx2
+ (package (inherit python-networkx)
+ (name "python-networkx2")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "networkx" version ".zip"))
+ (sha256
+ (base32
+ "1ajl2jp8qry9nyjzzkqpy0vmsr14d23z1qk7y0vr5iwjbpvzhpyd"))
+ (patches
+ (search-patches "python-networkx2-reproducible-build.patch"))))))
+
+(define-public python2-networkx2
+ (package-with-python2 python-networkx2))
+
(define-public snakemake
(package
(name "snakemake")