summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-06 11:34:00 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-09 10:29:55 +0100
commitad320b20ee2f90fb92c88d6f7c79d1611e6647d4 (patch)
treee139ba4cc14ddb9b1fd250607416e3812d1d8578 /gnu/packages/python.scm
parentd7678942f9a4a4f046e0781ab89ce62680ded24c (diff)
gnu: Add Sphinx RTD theme.
* gnu/packages/python.scm (python-sphinx-rtd-theme, python2-sphinx-rtd-theme): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1153b4f180..36acfc0ed3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1897,6 +1898,39 @@ sources.")
(define-public python2-sphinx
(package-with-python2 python-sphinx))
+(define-public python-sphinx-rtd-theme
+ (package
+ (name "python-sphinx-rtd-theme")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/s/"
+ "sphinx_rtd_theme/sphinx_rtd_theme-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "19nw3rn7awplcdrz63kg1njqwkbymfg9lwn7l2grhdyhyr2gaa8g"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; With standard flags, the install phase attempts to create a zip'd
+ ;; egg file, and fails with an error: 'ZIP does not support timestamps
+ ;; before 1980'
+ #:configure-flags '("--single-version-externally-managed"
+ "--record=sphinx-rtd-theme.txt")))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (inputs
+ `(("python-docutils" ,python-docutils)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/snide/sphinx_rtd_theme/")
+ (synopsis "ReadTheDocs.org theme for Sphinx")
+ (description "A theme for Sphinx used by ReadTheDocs.org.")
+ (license expat)))
+
+(define-public python2-sphinx-rtd-theme
+ (package-with-python2 python-sphinx-rtd-theme))
+
(define-public python-cython
(package
(name "python-cython")