summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-13 13:42:51 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-13 15:03:10 -0800
commitcb34dc6c3e2ce4658ac84dd192bdecf3fa795cfc (patch)
treebb27c6a84605da2f88b490adfeee9d67f9fda6fa /gnu/packages/python.scm
parentf97c91757d976d037ae2afd51e10531fc4b474d4 (diff)
gnu: Add python-wtforms
* gnu/packages/python.scm (python-wtforms, python2-wtforms): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 88c432699b..292423708e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7503,3 +7503,32 @@ input. (Note that this is mostly a legacy library; you may wish to look at
python-xdo for newer bindings.)")
(license bsd-3)))
+(define-public python-wtforms
+ (package
+ (name "python-wtforms")
+ (version "2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "WTForms" version ".zip"))
+ (sha256
+ (base32
+ "0vyl26y9cg409cfyj8rhqxazsdnd0jipgjw06civhrd53yyi1pzz"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "http://wtforms.simplecodes.com/")
+ (synopsis
+ "Form validation and rendering library for Python web development")
+ (description
+ "WTForms is a flexible forms validation and rendering library
+for Python web development. It is very similar to the web form API
+available in Django, but is a standalone package.")
+ (license bsd-3)
+ (properties `((python2-variant . ,(delay python2-wtforms))))))
+
+(define-public python2-wtforms
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-wtforms)))
+ (inputs `(("python2-setuptools" ,python2-setuptools)))))