summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-28 00:58:40 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-28 00:58:40 +0200
commit1bb163b0dd07c8f2cfd7e91f1e428075cd3d5ed2 (patch)
treee688a7246080108af74d792dc1a0a8cc244b5fed /gnu/packages/python.scm
parent8b732bf6d93ad2cb529c3c5f886efe2625c5fb72 (diff)
gnu: python@2.7: Delete faulty test on mips64el only.
This amends 8b732bf6d93ad2cb529c3c5f886efe2625c5fb72 and avoids a rebuild. * gnu/packages/python.scm (python-2.7)[arguments] <pre-check>: When (%current-system) starts with "mips64el", delete Lib/test/test_ctypes.py.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 14f29f0784..2b42a2c343 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -125,9 +125,7 @@
"Lib/test/test_import.py"
"Lib/test/test_shutil.py"
"Lib/test/test_socket.py"
- "Lib/test/test_subprocess.py"
- ;; The following test apparently fails only on mips64el.
- "Lib/test/test_ctypes.py"))
+ "Lib/test/test_subprocess.py"))
#t))))
(outputs '("out"
"tk")) ;tkinter; adds 50 MiB to the closure
@@ -198,6 +196,13 @@
(lambda _
;; 'Lib/test/test_site.py' needs a valid $HOME
(setenv "HOME" (getcwd))
+ ,@(if (string-prefix? "mips64el" (%current-system))
+
+ ;; XXX: The following test fails on mips64el.
+ '((false-if-exception
+ (delete-file "Lib/test/test_ctypes.py")))
+
+ '())
#t))
(add-after
'unpack 'set-source-file-times-to-1980