summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-07-01 17:40:02 -0400
committerLeo Famulari <leo@famulari.name>2016-07-03 22:24:44 -0400
commit936984b421eebdfcd5870599d5cad9dab2d3b297 (patch)
tree7f8749de34d9d75d8d06bff2788327ee0b26a242 /gnu/packages/python.scm
parentafcb871954bcafff9aa5969a8a92777647ae2fef (diff)
gnu: Add python-snowballstemmer.
* gnu/packages/python.scm (python-snowballstemmer, python2-snowballstemmer): New variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index da6dde5d3a..4479dddb2d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9727,3 +9727,25 @@ the default Sphinx theme.")
(native-inputs
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+
+(define-public python-snowballstemmer
+ (package
+ (name "python-snowballstemmer")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "snowballstemmer" version))
+ (sha256
+ (base32
+ "0a0idq4y5frv7qsg2x62jd7rd272749xk4x99misf5rcifk2d7wi"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
+ (synopsis "Snowball stemming library collection for Python")
+ (description "This package provides 16 stemmer algorithms generated from
+Snowball algorithms.")
+ (home-page "https://github.com/shibukawa/snowball_py")
+ (license bsd-2)))
+
+(define-public python2-snowballstemmer
+ (package-with-python2 python-snowballstemmer))