summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-04-07 16:32:16 -0400
committerMark H Weaver <mhw@netris.org>2014-04-07 17:41:48 -0400
commit32d5c729522d02fe973cb245fe26262f040e0c13 (patch)
treeefe43cb7adad3bb2e4de5c55a5a8cdb9464af8d8 /gnu/packages/python.scm
parentd013fe50ba28e5fca813ce067f416477b8041694 (diff)
gnu: python: Apply mips n32 fix to bundled libffi.
* gnu/packages/patches/python-libffi-mips-n32-fix.patch: New file. * gnu/packages/python.scm (python-2, python): Add it. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4bee529557..372f763ee5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +51,8 @@
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
+ (patches (list (search-patch "python-libffi-mips-n32-fix.patch")))
+ (patch-flags '("-p0"))
(sha256
(base32
"18gnpyh071dxa0rv3silrz92jw9qpblswzwv4gzqcwxzz20qxmhz"))))
@@ -190,7 +193,8 @@ data types.")
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
- (patches (list (search-patch "python-fix-tests.patch")))
+ (patches (list (search-patch "python-fix-tests.patch")
+ (search-patch "python-libffi-mips-n32-fix.patch")))
(patch-flags '("-p0"))
(sha256
(base32