summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-28 13:40:10 -0400
committerLeo Famulari <leo@famulari.name>2016-10-28 13:40:17 -0400
commita6447e7fb6a12f4a15b6bcffe09d97f78564f325 (patch)
treea99f5d0348c947b7eb002238bcf4293813081a5c /gnu/packages/python.scm
parentaa98b3b2738ea84a5a68b0680fdd4f174b94a9ca (diff)
parente359b31a60b29209a202a4012069f551bae8870f (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9b25b3ff62..25fcfa379e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4836,15 +4836,25 @@ libxml2 and libxslt.")
(define-public python-beautifulsoup4
(package
(name "python-beautifulsoup4")
- (version "4.5.0")
+ (version "4.5.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "beautifulsoup4" version))
(sha256
(base32
- "1rf94360s8pmn37vxqjl0g74krq2p6nj3wbn6pj94ik6ny44q24f"))))
+ "1qgmhw65ncsgccjhslgkkszif47q6gvxwqv4mim17agxd81p951w"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; The Python 2 source is the definitive source of beautifulsoup4. We
+ ;; must use this conversion script when building with Python 3. The
+ ;; conversion script also runs the tests.
+ ;; For more information, see the file 'convert-py3k' in the source
+ ;; distribution.
+ (replace 'check
+ (lambda _ (zero? (system* "./convert-py3k")))))))
(home-page
"http://www.crummy.com/software/BeautifulSoup/bs4/")
(synopsis
@@ -4862,7 +4872,8 @@ converts incoming documents to Unicode and outgoing documents to UTF-8.")
(package
(inherit (package-with-python2
(strip-python2-variant python-beautifulsoup4)))
- (native-inputs `(("python2-setuptools" ,python2-setuptools)))))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)))
+ (arguments `(#:python ,python-2))))
(define-public python2-cssutils
(package
@@ -8191,6 +8202,11 @@ server with very acceptable performance.")
(base32
"13kf9bdxrc95y9vriaz0viry3ah11nz4rlrykcfvb8nlqpx3dcm4"))))
(build-system python-build-system)
+ (arguments
+ '(;; Wsgiproxy2's test suite requires Restkit, which does not yet fully
+ ;; support Python 3:
+ ;; https://github.com/benoitc/restkit/issues/140
+ #:tests? #f))
(native-inputs
`(("unzip" ,unzip)
("python-nose" ,python-nose)