summaryrefslogtreecommitdiff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-07 09:03:28 -0400
committerLeo Famulari <leo@famulari.name>2017-04-20 14:21:31 -0400
commitdfa663c963a7c0745f18cbfab4b45eb335742602 (patch)
tree18d897603c61f50e59265402e011c147909dc525 /gnu/packages/qemu.scm
parent7252964244cd81dbe24af418ae52a2a20bc054c7 (diff)
gnu: qemu: Update to 2.9.0 [security fixes].
Fixes CVE-2017-{5857,5973,5987,6058,6505,7377,7471,7718}. * gnu/packages/qemu.scm (qemu): Update to 2.9.0. [source]: Remove obsolete patches. * gnu/packages/patches/qemu-CVE-2016-10155.patch, gnu/packages/patches/qemu-CVE-2017-5525.patch, gnu/packages/patches/qemu-CVE-2017-5526.patch, gnu/packages/patches/qemu-CVE-2017-5552.patch, gnu/packages/patches/qemu-CVE-2017-5578.patch, gnu/packages/patches/qemu-CVE-2017-5579.patch, gnu/packages/patches/qemu-CVE-2017-5856.patch, gnu/packages/patches/qemu-CVE-2017-5898.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index e0b4695f3a..82367269ff 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -69,23 +69,14 @@
(define-public qemu
(package
(name "qemu")
- (version "2.8.1")
+ (version "2.9.0")
(source (origin
(method url-fetch)
(uri (string-append "http://wiki.qemu-project.org/download/qemu-"
version ".tar.xz"))
(sha256
(base32
- "0h342v4n44kh89yyfas4iazvhhsy5m5qk94vsjqpz5zpq1i2ykad"))
- (patches (search-patches "qemu-CVE-2016-10155.patch"
- "qemu-CVE-2017-5525.patch"
- "qemu-CVE-2017-5526.patch"
- "qemu-CVE-2017-5552.patch"
- "qemu-CVE-2017-5578.patch"
- "qemu-CVE-2017-5579.patch"
- "qemu-CVE-2017-5856.patch"
- "qemu-CVE-2017-5898.patch"
- ))))
+ "08mhfs0ndbkyqgw7fjaa9vjxf4dinrly656f6hjzvmaz7hzc677h"))))
(build-system gnu-build-system)
(arguments
'(;; Running tests in parallel can occasionally lead to failures, like: