summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-08 02:30:06 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-20 14:13:32 +0100
commite2435b60f11265ec6a2fffccda3b7a65393535cc (patch)
tree48217fba7c23ede9f0227782e3d28b57b789f5a7 /gnu/packages/qt.scm
parentc08fda0716aefe1b9bd45df024523fcdf7f7e941 (diff)
gnu: Add qxlsx.
* gnu/packages/qt.scm (qxlsx): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b32a78085d..76e9e519c7 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2022 Yash Tiwari <yasht@mailbox.org>
+;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1117,6 +1118,44 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
(description "The QtX11Extras module includes the library to access X11
from within Qt 5.")))
+(define-public qxlsx
+ (package
+ (name "qxlsx")
+ (version "1.4.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/QtExcel/QXlsx")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h95h96vz47cnfp62j7bx6ih725gbv005hm0cfqanfvqd5xd9qsg"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "../source/QXlsx"
+ "-DCMAKE_BUILD_TYPE=Release"
+ (string-append "-DCMAKE_INSTALL_PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "../source/TestExcel"
+ (invoke "qmake")
+ (invoke "make" "-j" (number->string (parallel-job-count)))
+ (invoke "./TestExcel"))))))))
+ (inputs
+ (list qtbase-5))
+ (home-page "https://qtexcel.github.io/QXlsx/")
+ (synopsis "C++ library to read/write Excel XLSX files using Qt")
+ (description
+ "QXlsx is a successor of QtXlsx and providies a functionality to work with Excel
+XLSX document format.")
+ (license license:expat)))
+
(define-public qtxmlpatterns
(package (inherit qtsvg-5)
(name "qtxmlpatterns")