summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-12 22:16:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 12:32:24 -0400
commite253911955aaf09a47600f6d0e5cc5cb554f217c (patch)
tree808ad4a270900617454ac39a2bacea7693d1aee1 /gnu/packages/qt.scm
parent72abf72062f0e813efb633e05b42c99c4bc78cff (diff)
gnu: qt-creator: Update to 11.0.1.
* gnu/packages/qt.scm (qt-creator): Update to 11.0.1. [source]: Adjust snippet. [arguments]: Adjust patch-paths phase. Disable the 'tst_process' failing tests. Series-changes: 2 - Delete fix-tests-build phase - Only one new test is now disabled
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm35
1 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5132d8553a..02e5a8879f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4890,7 +4890,7 @@ including @i{fix-its} for automatic refactoring.")
(define-public qt-creator
(package
(name "qt-creator")
- (version "9.0.0")
+ (version "11.0.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4904,7 +4904,6 @@ including @i{fix-its} for automatic refactoring.")
;; Remove bundled libraries, where supported.
;; TODO: package and unbundle litehtml
'("src/libs/3rdparty/yaml-cpp"
- "src/shared/qbs/src/shared/qtscript/src/3rdparty"
"tests/unit/unittest/3rdparty"
;; Marketplace recommends nonfree extensions;
;; remove it.
@@ -4915,7 +4914,7 @@ including @i{fix-its} for automatic refactoring.")
((".*marketplace/marketplace.qbs.*") ""))))
(sha256
(base32
- "1adyxs0cnqx14gwzkvh909c52449ia6y87n1r4qf6wwydhch43cs"))))
+ "0j90dv9micqsvj4r7iqd11szixr0mlpna4w5s2lnyqckjs6a0mm6"))))
(build-system qt-build-system)
(arguments
(list
@@ -4931,25 +4930,17 @@ including @i{fix-its} for automatic refactoring.")
#$output "/lib/qtcreator"))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-tests-build
- (lambda _
- ;; Add a missing link directive (see:
- ;; https://bugreports.qt.io/browse/QTCREATORBUG-28434).
- (substitute* "src/libs/tracing/CMakeLists.txt"
- (("DEPENDS Utils Qt5::Qml Qt5::Quick")
- "DEPENDS Utils Qt5::Quick")
- (("PUBLIC_DEPENDS Qt5::Widgets")
- "PUBLIC_DEPENDS Qt5::Widgets Qt5::Qml"))))
(add-after 'unpack 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* '("src/libs/utils/commandline.cpp"
"src/libs/utils/deviceshell.cpp")
(("/bin/sh")
(search-input-file inputs "bin/sh")))
- (substitute* "src/libs/utils/qtcprocess.cpp"
+ (substitute* "src/libs/utils/process.cpp"
(("/usr/bin/env")
(search-input-file inputs "bin/env")))
- (substitute* "tests/auto/utils/qtcprocess/tst_qtcprocess.cpp"
+ (substitute* '("tests/auto/utils/process/tst_process.cpp"
+ "tests/auto/utils/commandline/tst_commandline.cpp")
(("/bin/sh")
(which "sh")))))
(add-before 'build 'build-doc
@@ -4962,7 +4953,6 @@ including @i{fix-its} for automatic refactoring.")
(invoke "cmake" "--install" "." "--prefix" #$output
"--component=html_docs")))
(replace 'check
- ;; Loosely based on .github/workflows/build_cmake.yml.
(lambda* (#:key tests? parallel-tests? #:allow-other-keys)
(when tests?
(invoke "xvfb-run" ;for the 'renderpass' tests
@@ -4970,7 +4960,20 @@ including @i{fix-its} for automatic refactoring.")
(number->string (parallel-job-count))
"1")
"--label-exclude" "exclude_from_precheck"
- "--exclude-regex" "tst_perfdata"))))
+ "-E"
+ (string-append
+ "("
+ (string-join
+ (list
+ ;; The performance data tests require external
+ ;; data.
+ "tst_perfdata"
+ ;; This test relies on counting processes, counts
+ ;; only 0 of them instead of 5 for unknown reasons
+ ;; (see:
+ ;; https://bugreports.qt.io/browse/QTCREATORBUG-29495).
+ "tst_process") "|")
+ ")")))))
(add-after 'qt-wrap 'wrap-bin
;; Make a few well-integrated tools readily available.
(lambda* (#:key inputs outputs #:allow-other-keys)