summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-27 05:22:31 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-27 05:22:31 +0100
commit4c70f5242befb5786cb437559a4d8701e630bd29 (patch)
treedbbff437004184d50c9a53f6c4897a85361aceb1 /gnu/packages/qt.scm
parenta9e65e0341d5045e425e3cf8d741a3d13cfa35a1 (diff)
parent929ddec8f4a181be653152c7436581c2adc54eee (diff)
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm60
1 files changed, 55 insertions, 5 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 761d12e31f..5866d33394 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -218,14 +218,14 @@ of C++20 coroutines in connection with certain asynchronous Qt actions.")
(define-public qt5ct
(package
(name "qt5ct")
- (version "1.5")
+ (version "1.8")
(source
(origin
(method url-fetch)
(uri
(string-append "mirror://sourceforge/qt5ct/qt5ct-" version ".tar.bz2"))
(sha256
- (base32 "14742vs32m98nbfb5mad0i8ciff5f45gfcb5v03p4hh2dvhhqgfn"))))
+ (base32 "1s88v3x5vxrz981jiqb9cnwak0shz6kgjbkp511i592y85a41dr3"))))
(build-system qt-build-system)
(arguments
(list
@@ -2171,7 +2171,18 @@ plugin for Adobe After Effects.")
"1bkx2sc5hyldarc7w76ymv7dlcna3ib9r2kp67jdqcf856bnrx36"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg-5)
- ((#:tests? _ #f) #f))) ; TODO: Enable the tests
+ ((#:tests? _ #f) #f) ; TODO: Enable the tests
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'patch-qmake
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Adjust the default location of the 'qmake' command known to
+ ;; the 'lprodump' command, which would otherwise look for it
+ ;; in its own bindir.
+ (substitute* "src/linguist/lprodump/main.cpp"
+ (("app.applicationDirPath\\() \\+ QLatin1String\\(\"/qmake\")")
+ (format #f "QLatin1String(~s)"
+ (search-input-file inputs "bin/qmake"))))))))))
(native-inputs (list perl qtdeclarative-5 vulkan-headers))
(inputs (list mesa qtbase-5))
(synopsis "Qt Tools and Designer modules")
@@ -2349,7 +2360,7 @@ control equipment. The module provides both QML and C++ interfaces. The
primary target audience are embedded devices with fullscreen user interfaces,
and mobile applications targeting TV-like form factors.")))
-(define-public qtscxml
+(define-public qtscxml-5
(package
(inherit qtsvg-5)
(name "qtscxml")
@@ -2377,6 +2388,45 @@ machines (loading the SCXML file and instantiating states and transitions) and
generating a C++ file that has a class implementing the state machine. It
also contains functionality to support data models and executable content.")))
+(define-public qtscxml
+ (package
+ (name "qtscxml")
+ (version "6.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-url name version))
+ (sha256
+ (base32
+ "1jxx9p7zi40r990ky991xd43mv6i8hdpnj2fhl7sf4q9fpng4c58"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "tests/3rdparty")))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check) ;move after the install phase
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "ARGS" "-E tst_scion")
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "QML2_IMPORT_PATH"
+ (string-append #$output "/lib/qt6/qml:"
+ (getenv "QML2_IMPORT_PATH"))))))))
+ (build-system cmake-build-system)
+ (inputs (list qtbase qtdeclarative libxkbcommon))
+ (synopsis "Qt SCXML module")
+ (description "The Qt SCXML module provides functionality to create state
+machines from SCXML files. This includes both dynamically creating state
+machines (loading the SCXML file and instantiating states and transitions) and
+generating a C++ file that has a class implementing the state machine. It
+also contains functionality to support data models and executable content.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtpositioning
(package
(name "qtpositioning")
@@ -4486,7 +4536,7 @@ color-related widgets.")
qtquickcontrols-5
qtquickcontrols2-5
qtscript
- qtscxml
+ qtscxml-5
qtsensors
qtspeech
qtsvg-5