summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-19 20:30:07 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:48 -0400
commitd9e8d7f4aa55877d81e1b6f276e5c26f28fef453 (patch)
tree9ff2fbbe38779e1a4c262604e3054225a7888d53 /gnu/packages/qt.scm
parent2e27ccec8307961feabbb85589ace67431672c70 (diff)
gnu: Add qtnetworkauth, version 6.3.1.
* gnu/packages/qt.scm (qtnetworkauth): New variable.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index daed19085d..16ce44035a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1981,6 +1981,26 @@ customized by using themes or by adding custom items and labels to them.")
(description "The Qt Network Authorization module provides an
implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
+(define-public qtnetworkauth
+ (package
+ (name "qtnetworkauth")
+ (version "6.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (qt5-urls name version))
+ (sha256
+ (base32
+ "0apvsb2ip1m3kw8vi9spvf6f6q72ys8vr40rpyysi7shsjwm83yn"))))
+ (build-system cmake-build-system)
+ (arguments (list #:configure-flags #~(list "-DQT_BUILD_TESTS=ON")))
+ (native-inputs (list perl))
+ (inputs (list qtbase))
+ (home-page (package-home-page qtbase))
+ (synopsis "Qt Network Authorization module")
+ (description "The Qt Network Authorization module provides an
+implementation of OAuth and OAuth2 authenticathon methods for Qt.")
+ (license (package-license qtbase))))
+
(define-public qtremoteobjects
(package (inherit qtsvg-5)
(name "qtremoteobjects")