summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-09-29 21:53:55 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-29 23:19:55 -0400
commita70c67cfe75031746d1f73ba76b6d83b95ea1cf7 (patch)
treef03f4eb10a058003d13bc9af67471f83f03509cb /gnu/packages/qt.scm
parent034f68bac3940420d6776f58522d6380023bb407 (diff)
gnu: Add qtwayland, version 6.3.1.
* gnu/packages/qt.scm (qtwayland): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f6e5a37472..6e30980505 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1500,6 +1500,56 @@ set of plugins for interacting with pulseaudio and GStreamer.")
(description "The Qt Wayland module provides the QtWayland client and
compositor libraries.")))
+(define-public qtwayland
+ (package
+ (name "qtwayland")
+ (version "6.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (sha256
+ (base32 "1w60p1did7awdlzq5k8vnq2ncpskb07cpvz31cbv99bjs6igw53g"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DQT_BUILD_TESTS=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; FIXME: tst_seatv4::animatedCursor() fails here.
+ ;; See also: <https://bugreports.qt.io/browse/QTBUG-78317>
+ (substitute* "tests/auto/client/seatv4/tst_seatv4.cpp"
+ (((string-append
+ "QVERIFY\\(!cursorSurface\\(\\)->"
+ "m_waitingFrameCallbacks\\.empty\\(\\)\\);")) "")
+ (("QTRY_COMPARE\\(bufferSpy\\.count\\(\\), 1\\);") ""))))
+ (add-before 'check 'set-test-environment
+ (lambda _
+ ;; Do not fail just because /etc/machine-id is missing.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ ;; Make Qt render "offscreen", required for tests.
+ (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+ (native-inputs (list glib perl pkg-config qtdeclarative))
+ (inputs
+ (list fontconfig
+ freetype
+ libx11
+ libxcomposite
+ libxext
+ libxkbcommon
+ libxrender
+ mesa
+ mtdev
+ qtbase
+ vulkan-headers
+ wayland))
+ (synopsis "Qt Wayland module")
+ (description "The Qt Wayland module provides the QtWayland client and
+compositor libraries.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtserialport
(package (inherit qtsvg-5)
(name "qtserialport")