summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-06-05 23:10:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-06-06 10:21:44 +0300
commit39766868a5d03a02a662be66b5286f710735822c (patch)
tree98cfd25c7581cc90c2e96a0740686cccc31dc937 /gnu/packages/qt.scm
parent8fa7f8d90736b0dfb1e76050b215f070eef31d26 (diff)
gnu: python-sip: Use 'modify-phases'.
* gnu/packages/qt.scm (python-sip)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2b8b8a7491..80a1c02f75 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -476,29 +476,28 @@ while JSON objects are mapped to QVariantMap.")
#:modules ((srfi srfi-1)
,@%gnu-build-system-modules)
#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (include (string-append out "/include"))
- (python (assoc-ref inputs "python"))
- (python-version
- (last (string-split python #\-)))
- (python-major+minor
- (string-join
- (take (string-split python-version #\.) 2)
- "."))
- (lib (string-append out "/lib/python"
- python-major+minor
- "/site-packages")))
- (zero?
- (system* "python" "configure.py"
- "--bindir" bin
- "--destdir" lib
- "--incdir" include))))
- %standard-phases)))
- (home-page "http://www.riverbankcomputing.com/software/sip/intro")
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (include (string-append out "/include"))
+ (python (assoc-ref inputs "python"))
+ (python-version
+ (last (string-split python #\-)))
+ (python-major+minor
+ (string-join
+ (take (string-split python-version #\.) 2)
+ "."))
+ (lib (string-append out "/lib/python"
+ python-major+minor
+ "/site-packages")))
+ (zero?
+ (system* "python" "configure.py"
+ "--bindir" bin
+ "--destdir" lib
+ "--incdir" include))))))))
+ (home-page "https://www.riverbankcomputing.com/software/sip/intro")
(synopsis "Python binding creator for C and C++ libraries")
(description
"SIP is a tool to create Python bindings for C and C++ libraries. It