summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-06-05 23:14:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-06-06 10:21:46 +0300
commiteef988c82edb3a83bca7b72946e8365dcd96a98e (patch)
tree8800273d520ab608861d7bfce2f588b58bb345b8 /gnu/packages/qt.scm
parent2be068136799b4b1ce332ef8785835f2fd4f037c (diff)
gnu: python-pyqt: Use 'modify-phases'.
* gnu/packages/qt.scm (python-pyqt)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm55
1 files changed, 27 insertions, 28 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index aaf5bc246c..8a2b4d6a0c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -543,34 +543,33 @@ module provides support functions to the automatically generated code.")
`(#:modules ((srfi srfi-1)
,@%gnu-build-system-modules)
#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (sip (string-append out "/share/sip"))
- (plugins (string-append out "/plugins"))
- (designer (string-append plugins "/designer"))
- (qml (string-append plugins "/PyQt5"))
- (python (assoc-ref inputs "python"))
- (python-version
- (last (string-split python #\-)))
- (python-major+minor
- (string-join
- (take (string-split python-version #\.) 2)
- "."))
- (lib (string-append out "/lib/python"
- python-major+minor
- "/site-packages")))
- (zero? (system* "python" "configure.py"
- "--confirm-license"
- "--bindir" bin
- "--destdir" lib
- "--designer-plugindir" designer
- "--qml-plugindir" qml
- "--sipdir" sip))))
- %standard-phases)))
- (home-page "http://www.riverbankcomputing.com/software/pyqt/intro")
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (sip (string-append out "/share/sip"))
+ (plugins (string-append out "/plugins"))
+ (designer (string-append plugins "/designer"))
+ (qml (string-append plugins "/PyQt5"))
+ (python (assoc-ref inputs "python"))
+ (python-version
+ (last (string-split python #\-)))
+ (python-major+minor
+ (string-join
+ (take (string-split python-version #\.) 2)
+ "."))
+ (lib (string-append out "/lib/python"
+ python-major+minor
+ "/site-packages")))
+ (zero? (system* "python" "configure.py"
+ "--confirm-license"
+ "--bindir" bin
+ "--destdir" lib
+ "--designer-plugindir" designer
+ "--qml-plugindir" qml
+ "--sipdir" sip))))))))
+ (home-page "https://www.riverbankcomputing.com/software/pyqt/intro")
(synopsis "Python bindings for Qt")
(description
"PyQt is a set of Python v2 and v3 bindings for the Qt application