summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-18 01:52:33 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:07 +0100
commit293ab255b24d9a3abb709611af604a59249322f9 (patch)
tree1e2d299e4d5debd90fc2a7947d39884f3b2c062f /gnu/packages/qt.scm
parent6d98b42ca537b3016a60b14dee3978b1b1c62b7a (diff)
gnu: Add signond.
* gnu/packages/qt.scm (signond): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9d1c0f6b5f..757a920056 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4284,6 +4284,51 @@ services using the XML based SOAP protocol and without the need for a dedicated
web server.")
(license (list license:gpl2 license:gpl3))))
+(define-public signond
+ (package
+ (name "signond")
+ (version "8.61")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/accounts-sso/signond")
+ (commit (string-append "VERSION_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0k6saz5spys4a4p6ws0ayrjks2gqdqvz7zfmlhdpz5axha0gbqq4"))))
+ (build-system qt-build-system)
+ (native-inputs (list doxygen pkg-config qtbase-5 qttools-5))
+ (inputs (list dbus glib libaccounts-glib))
+ (arguments
+ (list #:tests? #f ; Figure out how to run tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'validate-runpath)
+ (replace 'configure
+ (lambda _
+ (substitute* "src/signond/signond.pro"
+ (("/etc/")
+ (string-append #$output "/etc/")))
+ (substitute*
+ '("tests/extensions/extensions.pri"
+ "tests/signond-tests/mock-ac-plugin/plugin.pro"
+ "tests/signond-tests/identity-tool.pro"
+ "tests/signond-tests/mock-ac-plugin/identity-ac-helper.pro"
+ "tests/libsignon-qt-tests/libsignon-qt-tests.pro"
+ "tests/signond-tests/signond-tests.pri")
+ (("QMAKE_RPATHDIR = \\$\\$\\{QMAKE_LIBDIR\\}")
+ (string-append "QMAKE_RPATHDIR = "
+ #$output "/lib:"
+ #$output "/lib/signon")))
+ (invoke "qmake"
+ (string-append "PREFIX=" #$output)
+ (string-append "LIBDIR=" #$output "/lib")))))))
+ (home-page "http://accounts-sso.gitlab.io/signond/index.html")
+ (synopsis "Perform user authentication over D-Bus")
+ (description "This package provides a D-Bus service which performs user
+authentication on behalf of its clients.")
+ (license license:lgpl2.1+)))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar