summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-19 16:54:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:48 -0400
commita4784b32731f7289a045515486adf26d001c45ef (patch)
tree88e35dfef95e7a13ca07176840a5315a3e0218b0 /gnu/packages/qt.scm
parenteef8e2ec46c4155980815e00a394428c0c3de075 (diff)
gnu: Add qttools, version 6.3.1.
* gnu/packages/qt.scm (qttools): New variable.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index f0278c00a0..342b872275 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1723,6 +1723,33 @@ positioning and geolocation plugins.")))
the documentation, translate applications, generate help files and other stuff
that helps in Qt development.")))
+(define-public qttools
+ (package
+ (name "qttools")
+ (version "6.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (qt5-urls name version))
+ (sha256
+ (base32
+ "1h96w4bzkbd80vr7lh6hnypdlmbzc1y52c2zrqzvkgm3587pa4n4"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ ;; The build system attempts to fetch online resources and fails when
+ ;; building the test suite.
+ #:configure-flags #~(list "-DQT_BUILD_TESTS=OFF")))
+ (native-inputs (list perl qtdeclarative vulkan-headers))
+ (inputs (list libxkbcommon mesa qtbase))
+ (home-page (package-home-page qtbase))
+ (synopsis "Qt Tools and Designer modules")
+ (description "The Qt Tools module provides a set of applications to browse
+the documentation, translate applications, generate help files and other stuff
+that helps in Qt development.")
+ ;; GPL 3 only with Qt GPL exception 1.0 (see:
+ ;; LICENSES/Qt-GPL-exception-1.0.txt).
+ (license (list license:gpl3))))
+
(define-public qtscript
(package (inherit qtsvg-5)
(name "qtscript")