summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-18 07:49:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:46 -0400
commitef648459df868be6a44c7bfdb491e8e50bb9bfc6 (patch)
tree2c7813f4518d6902602b816cb11a7546b3635ff3 /gnu/packages/qt.scm
parent0938c3e34a9004948baa56bb21017d20fb9c9c26 (diff)
gnu: Add qtwebchannel, version 6.3.1.
* gnu/packages/qt.scm (qtwebchannel): New variable.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ce2e3ad8cc..3f1f468b7e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1561,6 +1561,43 @@ between the host (QML/C++ application) and the client (HTML/JavaScript
application). The transport mechanism is supported out of the box by the two
popular web engines, Qt WebKit 2 and Qt WebEngine.")))
+(define-public qtwebchannel
+ (package
+ (name "qtwebchannel")
+ (version "6.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (qt5-urls name version))
+ (sha256
+ (base32
+ "0s16zx3qn3byldvhmsnwijm8rmizk8vpqj7fnwhjg6c67z10m8ma"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags #~(list "-DQT_BUILD_TESTS=ON")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'check) ;move after install
+ (add-after 'install 'prepare-for-tests
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "QML2_IMPORT_PATH"
+ (string-append #$output "/lib/qt6/qml:"
+ (getenv "QML2_IMPORT_PATH")))))
+ (add-after 'prepare-for-tests 'check
+ (assoc-ref %standard-phases 'check))
+ (add-after 'check 'delete-installed-tests
+ (lambda _
+ (delete-file-recursively
+ (string-append #$output "/tests")))))))
+ (native-inputs (list perl))
+ (inputs (list qtbase qtdeclarative qtwebsockets))
+ (home-page (package-home-page qtbase))
+ (synopsis "Web communication library for Qt")
+ (description "The Qt WebChannel module enables peer-to-peer communication
+between the host (QML/C++ application) and the client (HTML/JavaScript
+application).")
+ (license (package-license qtbase))))
+
(define-public qtwebglplugin
(package (inherit qtsvg-5)
(name "qtwebglplugin")