summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-04 23:13:26 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-09 13:04:17 +0100
commit43e8824d3cd3ff53671167ab9b41f0094458a4d6 (patch)
tree5e6aeab008aa1bd3765ff0a7a2c2920c178639a9 /gnu/packages/qt.scm
parent931eaeaad9ef59cad651b6bd548a6151ac53d1d3 (diff)
gnu: python-pyqt: Fix build by explicitly setting the stubsdir.
* gnu/packages.qt.scm (python-pyqt, python2-pyqt)[arguments]: In phase 'configure' pass option --stubsdir.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index aaa7e1cff7..4a8fb6c66d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1015,13 +1015,19 @@ module provides support functions to the automatically generated code.")
"."))
(lib (string-append out "/lib/python"
python-major+minor
- "/site-packages")))
+ "/site-packages"))
+ (stubs (string-append lib "/PyQt5")))
(zero? (system* "python" "configure.py"
"--confirm-license"
"--bindir" bin
"--destdir" lib
"--designer-plugindir" designer
"--qml-plugindir" qml
+ ; Where to install the PEP 484 Type Hints stub
+ ; files. Without this the stubs are tried to be
+ ; installed into the python package's
+ ; site-package directory, which is read-only.
+ "--stubsdir" stubs
"--sipdir" sip))))))))
(home-page "https://www.riverbankcomputing.com/software/pyqt/intro")
(synopsis "Python bindings for Qt")