summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-17 23:17:31 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-26 15:38:39 -0500
commit41e95150a07f4cd736d33a812638439562e4e170 (patch)
treebfb005124b6bdce0544a5ca63bfa08f0c8b3b71d /gnu/packages/qt.scm
parent28d53c0241555fa8959cbbd50708c56a003e29a0 (diff)
gnu: qt-creator: Add support for demangling D and Rust symbols.
* gnu/packages/qt.scm (qt-creator) [inputs]: Add d-demangler and rust-rustc-demangle-capi-0.1 (where supported). Change-Id: I13122c0d148f283268d59919ade1459b5c7012a5
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm41
1 files changed, 24 insertions, 17 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a8244d1d1e..353b90823d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -71,9 +71,11 @@
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
+ #:use-module (gnu packages crates-io)
#:use-module (gnu packages cups)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages dlang)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
#:use-module (gnu packages enchant)
@@ -5172,23 +5174,28 @@ including @i{fix-its} for automatic refactoring.")
vulkan-headers
xvfb-run))
(inputs
- (list bash-minimal
- coreutils-minimal
- clang
- clazy
- elfutils
- gdb
- kcachegrind
- libxkbcommon
- llvm
- qt5compat
- qtdeclarative
- qtshadertools
- qtsvg
- yaml-cpp
- valgrind
- vulkan-loader
- `(,zstd "lib")))
+ (append
+ (list bash-minimal
+ coreutils-minimal
+ clang
+ clazy
+ d-demangler
+ elfutils
+ gdb
+ kcachegrind
+ libxkbcommon
+ llvm
+ qt5compat
+ qtdeclarative
+ qtshadertools
+ qtsvg
+ yaml-cpp
+ valgrind
+ vulkan-loader
+ `(,zstd "lib"))
+ (if (supported-package? rust-rustc-demangle-capi-0.1)
+ (list rust-rustc-demangle-capi-0.1)
+ '())))
(home-page "https://www.qt.io/")
(synopsis "Integrated development environment (IDE) for Qt")
(description "Qt Creator is an IDE tailored to the needs of Qt developers.