summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-01-16 11:40:42 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2023-01-16 13:48:42 +0100
commit99ea0702745e8ae13c0ce5501399beab4ed85330 (patch)
tree253a93439caa947c343e36d0eab8de70307e6dd1 /gnu/packages/radio.scm
parent2e652e687e23f95a5a2f5ef9dd895fe1f01251a3 (diff)
gnu: Add gqrx-scanner.
* gnu/packages/radio.scm (gqrx-scanner): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 5cc3bf077a..06682314a8 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2017, 2018, 2019, 2020, 2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019, 2020 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
-;;; Copyright © 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020, 2021, 2022, 2023 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2020 Charlie Ritter <chewzerita@posteo.net>
;;; Copyright © 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -1027,6 +1027,29 @@ using GNU Radio and the Qt GUI toolkit.")
(home-page "https://gqrx.dk/")
(license license:gpl3+)))
+(define-public gqrx-scanner
+ (package
+ (name "gqrx-scanner")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/neural75/gqrx-scanner")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ar8kqfrd768l6y4kqgq3467xckrrpaq8zlwzz5l7lp8r41w5plr"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; No test suite
+ (synopsis "Frequency scanner for Gqrx")
+ (description
+ "This package provides a frequency scanner for the Gqrx software-defined
+radio receiver.")
+ (home-page "https://github.com/neural75/gqrx-scanner")
+ (license license:expat)))
+
(define-public fldigi
(package
(name "fldigi")