summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-05-04 17:30:22 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-05-04 17:30:22 +0200
commitf14d3944cc699d1426c31b304fb49b72a579666a (patch)
treed4628eaa138aae0dd99b5bf8c1e9f919784955e0 /gnu/packages/radio.scm
parent6fad6aa1e363ccfb2d0cb31cb225f38bc60c9621 (diff)
gnu: airspyhf: Update to 1.6.8-1.40836c5.
* gnu/packages/radio.scm (airspyhf): Update to 1.6.8-1.40836c5.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm86
1 files changed, 44 insertions, 42 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 0b308e7874..64704cf093 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -277,51 +277,53 @@ this package. E.g.: @code{(udev-rules-service 'rtl-sdr rtl-sdr)}")
(license license:gpl2+))))
(define-public airspyhf
- (package
- (name "airspyhf")
- (version "1.6.8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/airspy/airspyhf")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0n699i5a9fzzhf80fcjlqq6p2a013rzlwmwv4nmwfafy6c8cr924"))))
- (build-system cmake-build-system)
- (native-inputs
- (list pkg-config))
- (inputs
- (list libusb))
- (arguments
- '(#:configure-flags '("-DINSTALL_UDEV_RULES=ON")
- #:tests? #f ; No tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "tools/CMakeLists.txt"
- (("DESTINATION \"/etc/udev/")
- (string-append "DESTINATION \""
- (assoc-ref outputs "out")
- "/lib/udev/")))))
- (add-after 'fix-paths 'fix-udev-rules
- (lambda _
- (substitute* "tools/52-airspyhf.rules"
- ;; The plugdev group does not exist; use dialout as in
- ;; the hackrf package.
- (("GROUP=\"plugdev\"")
- "GROUP=\"dialout\"")))))))
- (home-page "https://github.com/airspy/airspyhf")
- (synopsis "Software defined radio driver for Airspy HF+")
- (description
- "This package provides the driver and utilities for controlling the Airspy
-HF+ Software Defined Radio (SDR) over USB.
+ (let ((commit "40836c59d35d989fe00ac12ef774df736a36c6e4")
+ (revision "1"))
+ (package
+ (name "airspyhf")
+ (version (git-version "1.6.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/airspy/airspyhf")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s3fm856smvja3cg6fy615igir8wb0dzbp0q25v3vls0qj6pvprb"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list libusb))
+ (arguments
+ '(#:configure-flags '("-DINSTALL_UDEV_RULES=ON")
+ #:tests? #f ; No tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "tools/CMakeLists.txt"
+ (("DESTINATION \"/etc/udev/")
+ (string-append "DESTINATION \""
+ (assoc-ref outputs "out")
+ "/lib/udev/")))))
+ (add-after 'fix-paths 'fix-udev-rules
+ (lambda _
+ (substitute* "tools/52-airspyhf.rules"
+ ;; The plugdev group does not exist; use dialout as in
+ ;; the hackrf package.
+ (("GROUP=\"plugdev\"")
+ "GROUP=\"dialout\"")))))))
+ (home-page "https://github.com/airspy/airspyhf")
+ (synopsis "Software defined radio driver for Airspy HF+")
+ (description
+ "This package provides the driver and utilities for controlling the
+Airspy HF+ Software Defined Radio (SDR) over USB.
To install the airspyhf udev rules, you must extend @code{udev-service-type}
with this package. E.g.: @code{(udev-rules-service 'airspyhf airspyhf)}")
- (license license:bsd-3)))
+ (license license:bsd-3))))
(define-public soapysdr
(package