summaryrefslogtreecommitdiff
path: root/gnu/packages/rails.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-13 11:31:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:38 -0400
commitefbdb3452b25d6f130dfff40f95598e4107c1344 (patch)
tree19a27f385070a7c32f971fc016a3eec3850df5ce /gnu/packages/rails.scm
parent7cb3ca626020cca1e3e372fe82837d774397440d (diff)
gnu: Add ruby-propshaft.
* gnu/packages/rails.scm (ruby-propshaft): New variable.
Diffstat (limited to 'gnu/packages/rails.scm')
-rw-r--r--gnu/packages/rails.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
index fbb85f271d..8f174920ec 100644
--- a/gnu/packages/rails.scm
+++ b/gnu/packages/rails.scm
@@ -905,6 +905,30 @@ Extensions} type detection using magic numbers, filenames, and extensions")
(home-page "https://github.com/rails/marcel")
(license license:expat)))
+(define-public ruby-propshaft
+ (package
+ (name "ruby-propshaft")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "propshaft" version))
+ (sha256
+ (base32
+ "19s5qvfady49b9b6dcvz6nsna1lvckw509ddh3ihmdz0w4qrjy49"))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list ruby-actionpack ruby-activesupport ruby-rack
+ ruby-railties))
+ (synopsis "Asset pipeline library for Rails")
+ (description "Propshaft is an asset pipeline library for Rails. It's
+built for an era where bundling assets to save on HTTP connections is no
+longer urgent, where JavaScript and CSS are either compiled by dedicated
+Node.js bundlers or served directly to the browsers, and where increases in
+bandwidth have made the need for minification less pressing. These factors
+allow for a dramatically simpler and faster asset pipeline compared to
+previous options, like Sprockets.")
+ (home-page "https://github.com/rails/propshaft")
+ (license license:expat)))
+
;;; Pro-tip: to get a summary of the failures, run
;;; 'M-x occur [1-9][0-9]* \(failures\|errors\)' on the build log.
(define-public ruby-railties