summaryrefslogtreecommitdiff
path: root/gnu/packages/raspberry-pi.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-05 00:46:25 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-18 21:33:26 -0500
commit6ba3ed13ef5c0db627a9b19882389c96eb14578e (patch)
treee26696d8160faccad97efaf38e0629e62ee9325d /gnu/packages/raspberry-pi.scm
parent6c11c75702969f810eb216d973912a5cdf286d34 (diff)
gnu: Add rpi-fbcp.
* gnu/packages/raspberry-pi.scm (rpi-fbcp): New variable.
Diffstat (limited to 'gnu/packages/raspberry-pi.scm')
-rw-r--r--gnu/packages/raspberry-pi.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/raspberry-pi.scm b/gnu/packages/raspberry-pi.scm
index 57f9de4c5c..4c7da7376b 100644
--- a/gnu/packages/raspberry-pi.scm
+++ b/gnu/packages/raspberry-pi.scm
@@ -428,6 +428,41 @@ also provides the @command{dtmerge}, @command{dtoverlay}, @command{dtparam},
@command{raspivid} and @command{tvservice} commands, among others.")
(license license:bsd-3))))
+(define-public rpi-fbcp
+ ;; There are no release nor tag; use the latest commit.
+ (let ((revision "0")
+ (commit "af8d32246c23cb23e4030e6588668a14341f5ddc"))
+ (package
+ (name "rpi-fbcp")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tasanakorn/rpi-fbcp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10wym2jckicxm5iwqgby6gbhkznyi1q8x41v0qahzv71x85xpsl5"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ ;; There is no installation target.
+ (lambda _
+ (install-file "fbcp" (string-append #$output "/bin")))))))
+ (inputs (list raspberrypi-userland))
+ (home-page "https://github.com/tasanakorn/rpi-fbcp")
+ (synopsis "Mirror primary to secondary frame buffer on Raspberry Pi")
+ (description "The @command{fbcp} command provided by this package can be
+used to copy the primary frame buffer to the secondary frame buffer of a
+Raspberry Pi. It can for example mirror the primary HDMI output to a
+secondary LCD display connected to the Raspberry Pi board.")
+ (license license:expat))))
+
(define-public rpi-imager
(package
(name "rpi-imager")