summaryrefslogtreecommitdiff
path: root/gnu/packages/rpm.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:41:03 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:08 -0400
commitaee7fc2e41059e81050087deb0573b99ca868b95 (patch)
tree9015c164e824c7589b68ce9dd9c1c929686824c5 /gnu/packages/rpm.scm
parent5fc9edc351d237dabf7b312859558fb788b1e5bc (diff)
gnu: libmodulemd: Remove fix-docbook-references phase.
* gnu/packages/rpm.scm (libmodulemd) [arguments]: Remove fix-docbook-references phase. [native-inputs]: Add libxml2.
Diffstat (limited to 'gnu/packages/rpm.scm')
-rw-r--r--gnu/packages/rpm.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/rpm.scm b/gnu/packages/rpm.scm
index 0b6cacadef..b7802e3ecd 100644
--- a/gnu/packages/rpm.scm
+++ b/gnu/packages/rpm.scm
@@ -105,14 +105,6 @@ applying deltarpms, compatible with the original deltarpm packages.")
(format #f "glib_docpath = '~a'~%"
(search-input-directory (or native-inputs inputs)
"share/gtk-doc/html"))))))
- (add-after 'unpack 'fix-docbook-references
- ;; gtk-doc doesn't seem to honor DocBook 4.1.2's docbook.cat's
- ;; catalog file, even when adding it to XML_CATALOG_FILES. Work
- ;; around it by adjusting the DocBook references directly.
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "modulemd/modulemd-docs.xml"
- (("http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd")
- (search-input-file inputs "xml/dtd/docbook/docbookx.dtd")))))
(add-after 'install 'move-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let ((dst (string-append #$output:doc "/share/gtk-doc")))
@@ -126,6 +118,7 @@ applying deltarpms, compatible with the original deltarpm packages.")
gobject-introspection ;for g-ir-scanner
gtk-doc
help2man
+ libxml2 ;for XML_CATALOG_FILES
pkg-config
python)) ;for 'site-packages' call
(inputs