summaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-19 01:42:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-19 01:42:40 +0100
commit32cd878be0bb7e153fcaa6f3bfa2632867390ff9 (patch)
treefc1ff93949817c9d172c84d0410ac9225cad57ae /gnu/packages/rsync.scm
parent753425610274ccb59cce13490c096027c61621d0 (diff)
parent98bd11cfe7b931e9c6d6bf002a8a225fb7a1025b (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index dba4e89a05..d7fc188af2 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,7 +39,15 @@
version ".tar.gz"))
(sha256
(base32
- "1hm1q04hz15509f0p9bflw4d6jzfvpm1d36dxjwihk1wzakn5ypc"))))
+ "1hm1q04hz15509f0p9bflw4d6jzfvpm1d36dxjwihk1wzakn5ypc"))
+ (patches (search-patches "rsync-CVE-2017-16548.patch"
+ "rsync-CVE-2017-17433.patch"
+ "rsync-CVE-2017-17433-fix-tests.patch"
+ "rsync-CVE-2017-17434-pt1.patch"
+ "rsync-CVE-2017-17434-pt2.patch"
+ ))
+ ))
+ (properties `((lint-hidden-cve . ("CVE-2017-15994")))) ; introduced after 3.1.2
(build-system gnu-build-system)
(inputs `(("perl" ,perl)
("acl" ,acl)))