summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-15 15:30:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:43 -0400
commit28078fb5059f6df7ed227856c9756712cd2888c1 (patch)
tree5a6c69fdfa8cc60adc9d18121870b0aeb444b335 /gnu/packages/ruby.scm
parent8a6707866a315c10de9d22ec417529e4368e61fe (diff)
gnu: Add ruby-minitest-profile.
* gnu/packages/ruby.scm (ruby-minitest-profile): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3f90febc43..0527e65970 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5284,6 +5284,23 @@ Minitest. It is inspired by the @code{test-unit-power_assert} gem.")
(home-page "https://github.com/hsbt/minitest-power_assert")
(license license:bsd-2)))
+(define-public ruby-minitest-profile
+ (package
+ (name "ruby-minitest-profile")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "minitest-profile" version))
+ (sha256
+ (base32
+ "13h4nwbq6yv7hsaa7dpj90lry4rc5qqnpzvm9n2s57mm2xi31xfa"))))
+ (build-system ruby-build-system)
+ (synopsis "Display the slowest tests in a MiniTest suite")
+ (description "This package provides a MiniTest plugin for displaying the
+slowest tests in a minitest suite.")
+ (home-page "https://github.com/nmeans/minitest-profile")
+ (license license:expat)))
+
(define-public ruby-minitest-pretty-diff
;; Use git reference because gem is out of date and does not contain testing
;; script. There are no releases on GitHub.