summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-15 13:45:17 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:42 -0400
commit602635d3739aa1527f92b8fda5f53a8e0685e9cb (patch)
treea2301275df72c5db3ec78bbef6a2bc0773638322 /gnu/packages/ruby.scm
parent0ef4d1af3394f180086f004e89f3de6e7b6e0c7b (diff)
gnu: ruby-prawn-svg: Fix build.
The test suite fails two tests when using a newer rspec version. * gnu/packages/ruby.scm (ruby-prawn-svg) [arguments]: Delete the interface_spec.rb test suite in the check phase.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 13 insertions, 9 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index febd1e80ce..3f90febc43 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1529,15 +1529,19 @@ Style Sheets (CSS) rule sets in Ruby.")
"0mbxzw7r7hv43db9422flc24ib9d8bdy1nasbni2h998jc5a5lb6"))))
(build-system ruby-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'do-not-use-bundler
- (lambda _
- (substitute* "spec/spec_helper.rb"
- ((".*[Bb]undler.*") ""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "rspec" "-Ilib" "-rprawn-svg")))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-use-bundler
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ ((".*[Bb]undler.*") ""))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; This test fails due to the recent rspec 3.12 used
+ ;; (see: https://github.com/mogest/prawn-svg/issues/151).
+ (delete-file "spec/prawn/svg/interface_spec.rb")
+ (invoke "rspec" "-Ilib" "-rprawn-svg")))))))
(native-inputs (list ruby-rspec))
(propagated-inputs (list ruby-css-parser ruby-prawn))
(synopsis "SVG renderer for the Prawn PDF library")