summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-13 10:49:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:28 -0400
commit95692655a1a954835128990f8dedeff4a256bf7a (patch)
tree936d69c4db6541fcc1ff01922dc4082e535518ac /gnu/packages/ruby.scm
parent2d877f6ef3f59e152ae37d72ce150a442baeb7eb (diff)
gnu: Add ruby-prawn-svg.
* gnu/packages/ruby.scm (ruby-prawn-svg): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c362500e8b..0a2b6f43a1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1212,6 +1212,42 @@ Style Sheets (CSS) rule sets in Ruby.")
(home-page "https://github.com/premailer/css_parser")
(license license:expat)))
+(define-public ruby-prawn-svg
+ (package
+ (name "ruby-prawn-svg")
+ (version "0.30.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "prawn-svg" version))
+ (sha256
+ (base32
+ "0df3l49cy3xpwi0b73hmi2ykbjg9kjwrvhk0k3z7qhh5ghmmrn77"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'do-not-use-bundler
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ ((".*[Bb]undler.*") ""))
+ #t))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec" "-Ilib" "-rprawn-svg"))
+ #t)))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)))
+ (propagated-inputs
+ `(("ruby-css-parser" ,ruby-css-parser)
+ ("ruby-prawn" ,ruby-prawn)))
+ (synopsis "SVG renderer for the Prawn PDF library")
+ (description "This library allows rendering Scalable Vector Graphics (SVG)
+graphics directly into a Portable Document Format (PDF) document using the
+Prawn module.")
+ (home-page "https://github.com/mogest/prawn-svg")
+ (license license:expat)))
+
(define-public ruby-ast
(package
(name "ruby-ast")