summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2023-07-26 21:33:53 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:44:01 +0100
commit9a6e232de0e4af3432fc74b6cdf5b1115fabb5ba (patch)
tree8481eb90da459b53d02ba5e09d11138748d0ee51 /gnu/packages/ruby.scm
parentb0d0c76dbec64d77fbc6e9b1a4f5b4c16e9f6160 (diff)
gnu: ruby-childprocess: Update to 4.1.0.
This change include code for making more tests pass. Anyhow, one is still failing for unclear reason, thus tests are still disabled. * gnu/packages/ruby.scm (ruby-childprocess): Update to 4.1.0. [arguments]{test-target}: New argument. {phases}: New argument [propagated-inputs]: Remove ruby-ffi. [native-inputs]: Remove bundler; add ruby-coveralls.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1b72220b33..de79813bfb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13133,21 +13133,26 @@ almost perfectly compatible with ruby 1.9's.")
(define-public ruby-childprocess
(package
(name "ruby-childprocess")
- (version "3.0.0")
+ (version "4.1.0")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "childprocess" version))
(sha256
(base32
- "1ic028k8xgm2dds9mqnvwwx3ibaz32j8455zxr9f4bcnviyahya5"))))
+ "1lvcp8bsd35g57f7wz4jigcw2sryzzwrpcgjwwf3chmjrjcww5in"))))
(build-system ruby-build-system)
(arguments
- `(#:tests? #f))
+ `(#:tests? #f ;; one failing test, even with fixes below
+ #:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "spec/spec_helper.rb"
+ (("#!/bin/sh\\\\n") (string-append "#!" (which "sh") "\\n"))))))))
(native-inputs
- (list bundler ruby-rspec))
- (propagated-inputs
- (list ruby-ffi))
+ (list ruby-coveralls ruby-rspec))
(synopsis "Control external programs running in the background, in Ruby")
(description "@code{childprocess} provides a gem to control external
programs running in the background, in Ruby.")