summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-05 21:43:33 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-05 22:37:00 -0500
commitec47da8f494480368efc7845b5b7cedade1968a7 (patch)
tree8cca86d1818da0ef9c4dfbcae356407733b4a3e5 /gnu/packages/ruby.scm
parentc2501fa8fc4d4f4b2353ead5c198840977e1d493 (diff)
gnu: ruby-asciidoctor: Update to 2.0.18.
* gnu/packages/ruby.scm (ruby-asciidoctor): Update to 2.0.18. [native-inputs]: Sort inputs. Add ruby-open-uri-cached. [phases]: Delete trailing #t. [description]: Remove mention of Docbook 4.5, no longer supported.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d83d43927a..7e26bdc618 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1261,7 +1261,7 @@ syntax to the minimum while remaining clear.")
(define-public ruby-asciidoctor
(package
(name "ruby-asciidoctor")
- (version "2.0.16")
+ (version "2.0.18")
(source
(origin
(method git-fetch) ;the gem release lacks a Rakefile
@@ -1271,7 +1271,7 @@ syntax to the minimum while remaining clear.")
(file-name (git-file-name name version))
(sha256
(base32
- "086i17v9rxx0sxac26xp8c5v75jqba6rqjlk57x94qjvrh8vzyw2"))))
+ "1mpk3y69lqz9ywfkjmr40dm3mkabrnf92bb011qq1axj73yyrajv"))))
(build-system ruby-build-system)
(arguments
`(#:test-target "test:all"
@@ -1282,26 +1282,25 @@ syntax to the minimum while remaining clear.")
(delete-file "Gemfile")
(substitute* "asciidoctor.gemspec"
(("(.*add_.*dependency '[_A-Za-z0-9-]+').*" _ stripped)
- (string-append stripped "\n")))
- #t)))))
+ (string-append stripped "\n"))))))))
(native-inputs
- (list ruby-erubi
- ruby-erubis
- ruby-minitest
- ruby-nokogiri
- ruby-asciimath
+ (list ruby-asciimath
ruby-coderay
ruby-cucumber
+ ruby-erubis
ruby-haml
+ ruby-minitest
+ ruby-nokogiri
+ ruby-open-uri-cached
ruby-rouge
ruby-rspec-expectations
ruby-simplecov
ruby-slim
- ruby-tilt))
+ ruby-tilt
+ ruby-erubi))
(synopsis "Converter from AsciiDoc content to other formats")
(description "Asciidoctor is a text processor and publishing toolchain for
-converting AsciiDoc content to HTML5, DocBook 5 (or 4.5), PDF, and other
-formats.")
+converting AsciiDoc content to HTML5, DocBook 5, PDF, and other formats.")
(home-page "https://asciidoctor.org")
(license license:expat)))