summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-07-25 08:16:22 -0400
committerLudovic Courtès <ludo@gnu.org>2022-08-04 12:05:50 +0200
commit033b2e61627957fb959cde113fa0868bb0e61f1f (patch)
tree3e4a280066c052724077a1f04d74a1e9427eb70f /gnu/packages/ruby.scm
parent5e27bcf358bc57c735ca38e5a87f645529db26a2 (diff)
gnu: Add ruby-rdf.
* gnu/packages/ruby.scm (ruby-rdf): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index bab120f8e0..f6d95604f4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13184,3 +13184,25 @@ to RFC 5988. Objects can be constructed from and converted to text or a
JSON-friendly @code{Array} representation. They can also be used to generate
corresponding HTML @code{link} elements.")
(license license:expat)))
+
+(define-public ruby-rdf
+ (package
+ (name "ruby-rdf")
+ (version "3.2.8")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rdf" version))
+ (sha256
+ (base32
+ "1cj0k8ryd8hgbkgqb5swvy6fiygxny3y5bln0my5gv6dbfv3gm20"))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list ruby-link-header))
+ (arguments
+ (list #:tests? #f)) ;; tests have many cyclic dependencies
+ (home-page "https://ruby-rdf.github.io/")
+ (synopsis "Linked Data for Ruby")
+ (description
+ "This gem contains the core algorithms and classes used for doing basic
+programming with @acronym{RDF, Resource Description Framework} data,
+implemented in pure Ruby.")
+ (license license:unlicense)))