summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-06 12:21:48 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-08 00:41:04 -0500
commit2dd677d0fce7337afe9fdc45d0bac8f8cfd91d89 (patch)
tree246b4fe3c5e694e2c34af7c5bceb896b788acabe /gnu/packages/ruby.scm
parentc16e11bb2f8e6068628a188e199614a07f80c861 (diff)
gnu: Add ruby-matrix.
* gnu/packages/ruby.scm (ruby-matrix): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b4fb4bf141..da255b4d9a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11233,6 +11233,31 @@ Ruby yaml library.")
(home-page "https://github.com/Pryz/yaml-lint")
(license license:expat)))
+(define-public ruby-matrix
+ (package
+ (name "ruby-matrix")
+ (version "0.4.2")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/ruby/matrix")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1asxr0jzh39lk5f8a9wm5avykrcy0v2wgd1bl3cszjczh99xy5k2"))))
+ (build-system ruby-build-system)
+ (synopsis "@code{Matrix} and @code{Vector} classes implementation for Ruby")
+ (description "This Ruby library provides an implementation of the
+@code{Matrix} and @code{Vector} classes. The @code{Matrix} class represents a
+mathematical matrix. It provides methods for creating matrices, operating on
+them arithmetically and algebraically, and determining their mathematical
+properties (trace, rank, inverse, determinant, eigensystem, etc.). The
+@code{Vector} class represents a mathematical vector, which is useful in its
+own right, and also constitutes a row or column of a @code{Matrix}.")
+ (home-page "https://github.com/ruby/matrix")
+ (license license:bsd-2)))
+
(define-public ruby-mercenary
(package
(name "ruby-mercenary")