summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-04 16:17:59 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:04 +0100
commitcd0daf65a082f547f374543e7b614454b8608e8c (patch)
treeb3832a7c689e6089068a118207e5ad9bbbee07fd /gnu/packages/ruby.scm
parenta1e6a360a516b729c7a26864b9744f82cbb54394 (diff)
gnu: ruby-sass-spec: Remove ruby-terminfo input.
As I don't think it's necessary. * gnu/packages/ruby.scm (ruby-sass-spec)[propagated-inputs]: Remove ruby-terminfo. [arguments]: Update style.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8eff241b24..0d7225797b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12965,20 +12965,20 @@ strings or files.")
(base32 "1zsw66830w0xlc7kxz6fm4b5nyb44vdsdgm9mgy06s5aixx83pwr"))))
(build-system ruby-build-system)
(propagated-inputs
- `(("ruby-command-line-reporter-3" ,ruby-command-line-reporter-3)
- ("ruby-diffy" ,ruby-diffy)
- ("ruby-terminfo" ,ruby-terminfo)))
+ (list ruby-command-line-reporter-3
+ ruby-diffy))
(arguments
- `(;; This package contains tests for a sass implementation, and the to
- ;; avoid any circular dependencies, the tests are not run here
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-test
- (lambda _
- (delete-file "spec/values/colors/alpha_hex-3.5/error")
- (substitute* "spec/values/colors/alpha_hex-3.5/expected_output.css"
- (("string") "color")))))))
+ (list
+ ;; This package contains tests for a sass implementation, and the to
+ ;; avoid any circular dependencies, the tests are not run here
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-test
+ (lambda _
+ (delete-file "spec/values/colors/alpha_hex-3.5/error")
+ (substitute* "spec/values/colors/alpha_hex-3.5/expected_output.css"
+ (("string") "color")))))))
(home-page "https://github.com/sass/sass-spec")
(synopsis "Test suite for Sass")
(description "Sass Spec is a test suite for Sass. Test cases are all in