summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-06 13:12:42 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-08 00:41:05 -0500
commitf7c803f998286ba48a72ae336162865f75308296 (patch)
tree700a22ad48cd2a33bef907b54923185b4a123e15 /gnu/packages/ruby.scm
parent7529d2b9c11023a5c3c0e5fad2b5438f500fb33b (diff)
gnu: ruby-prawn-svg: Update to 0.32.0.
* gnu/packages/ruby.scm (ruby-prawn-svg): Update to 0.32.0. Delete trailing #t and re-indent inputs.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 265e19589a..ac32552059 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1401,31 +1401,27 @@ Style Sheets (CSS) rule sets in Ruby.")
(define-public ruby-prawn-svg
(package
(name "ruby-prawn-svg")
- (version "0.30.0")
+ (version "0.32.0")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "prawn-svg" version))
(sha256
(base32
- "0df3l49cy3xpwi0b73hmi2ykbjg9kjwrvhk0k3z7qhh5ghmmrn77"))))
+ "0mbxzw7r7hv43db9422flc24ib9d8bdy1nasbni2h998jc5a5lb6"))))
(build-system ruby-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'unpack 'do-not-use-bundler
(lambda _
(substitute* "spec/spec_helper.rb"
- ((".*[Bb]undler.*") ""))
- #t))
+ ((".*[Bb]undler.*") ""))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "rspec" "-Ilib" "-rprawn-svg"))
- #t)))))
- (native-inputs
- (list ruby-rspec))
- (propagated-inputs
- (list ruby-css-parser ruby-prawn))
+ (invoke "rspec" "-Ilib" "-rprawn-svg")))))))
+ (native-inputs (list ruby-rspec))
+ (propagated-inputs (list ruby-css-parser ruby-prawn))
(synopsis "SVG renderer for the Prawn PDF library")
(description "This library allows rendering Scalable Vector Graphics (SVG)
graphics directly into a Portable Document Format (PDF) document using the