summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-07 18:20:23 +0200
committerMarius Bakke <marius@gnu.org>2022-09-07 18:20:23 +0200
commit6cfb2e6270b2759fb98a0de665235bcbb9b9eccf (patch)
tree83c467772a94cbf72f96b26b08f0a29d1822b1c1 /gnu/packages/ruby.scm
parent92fdda5a6351dd5246b65165547d50d0b827cef3 (diff)
parent453e7dd8c4b9422a7c80e3b3e75589b6471f5af1 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 6bc8f9e9a1..ee0c7bb72d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2021 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5374,6 +5375,24 @@ The output can be customized with a formatting system.")
(home-page "https://github.com/jfelchner/ruby-progressbar")
(license license:expat)))
+(define-public ruby-latest-ruby
+ (package
+ (name "ruby-latest-ruby")
+ (version "3.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "latest_ruby" version))
+ (sha256
+ (base32
+ "15rqwgxzpnkzdiz8m02jra0zq5sx0fiz61vkfrj1ls6slqfhnzqg"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; No Rakefile
+ (synopsis "Answers the question of what the latest Ruby version is")
+ (description "Knows about MRI, Rubinius, JRuby, MagLev and MacRuby.")
+ (home-page "https://github.com/kyrylo/latest_ruby")
+ (license license:zlib)))
+
(define-public ruby-pry
(package
(name "ruby-pry")
@@ -5397,6 +5416,29 @@ invocation, and source and documentation browsing.")
(home-page "https://cobaltbluemedia.com/pryrepl/")
(license license:expat)))
+(define-public ruby-pry-doc
+ (package
+ (name "ruby-pry-doc")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "pry-doc" version))
+ (sha256
+ (base32
+ "0wyvql6pb6m8jl8bsamabxhxhd86bnqblspaxzz05sl0fm2ynj0r"))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list ruby-pry ruby-yard))
+ (native-inputs (list ruby-latest-ruby ruby-rspec ruby-rake)) ;for tests
+ (synopsis "Provides YARD and extended documentation support for Pry")
+ (description
+ "Pry Doc is a Pry REPL plugin. It provides extended documentation
+support for the REPL by means of improving the @code{show-doc} and
+@code{show-source} commands. With help of the plugin the commands are
+be able to display the source code and the docs of Ruby methods and
+classes implemented in C.")
+ (home-page "https://github.com/pry/pry-doc")
+ (license license:expat)))
+
(define-public ruby-single-cov
(package
(name "ruby-single-cov")