summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-06 15:38:06 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-08 00:41:06 -0500
commitd163a379b9dbb57d1f249bf869cff9f535137687 (patch)
tree455874e1fa34d69fad8252f0afb13caf7a2dcd77 /gnu/packages/ruby.scm
parent8c002eefdf9b15736b5e4379c85ae135b225b1fa (diff)
gnu: ruby-html-proofer: Update to 5.0.3.
* gnu/packages/ruby.scm (ruby-html-proofer): Update to 5.0.3. [arguments]: Add replace-git-ls-files and relax-requirements phases. [native-inputs]: Delete field. [propagated-inputs]: Replace ruby-nokogumbo with ruby-nokogiri.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm37
1 files changed, 25 insertions, 12 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 67eec5db4e..f52503f70e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11565,7 +11565,7 @@ characteristics.")
(define-public ruby-html-proofer
(package
(name "ruby-html-proofer")
- (version "3.18.5")
+ (version "5.0.3")
(source
(origin
(method git-fetch)
@@ -11575,22 +11575,35 @@ characteristics.")
(file-name (git-file-name name version))
(sha256
(base32
- "1pxb0fajb3l3lm7sqj548qwl7vx6sx3jy7n4cns9d4lqx7s9r9xb"))))
+ "01ksss3ikppc45z2q33bx8bb9785bqlp1rdqascaqg9mhs392adk"))))
(build-system ruby-build-system)
(arguments
- `(;; FIXME: Tests depend on rubocop-standard.
- #:tests? #f))
- (native-inputs
- (list ruby-awesome-print
- ruby-redcarpet
- ruby-rspec
- ruby-rubocop
- ruby-rubocop-performance
- ruby-pry-byebug))
+ (list
+ ;; Tests require vcr, which is under the Hippocratic license, which is
+ ;; not a free software license (see:
+ ;; https://www.gnu.org/licenses/license-list.html#hippocratic).
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'extract-gemspec 'relax-requirements
+ (lambda _
+ (substitute* "html-proofer.gemspec"
+ (("required_ruby_version = \\[\">= 3.1\"")
+ "required_ruby_version = [\">= 2.6\""))))
+ (replace 'replace-git-ls-files
+ (lambda _
+ ;; The html-proofer.gemspec file contains 'all_files = %x(git
+ ;; ls-files -z).split("\x0")', but the original phase matches on
+ ;; `git ls-files -z`.
+ ;; TODO: Improve ruby-build-system patterns on core-updates.
+ (substitute* "html-proofer.gemspec"
+ (("git ls-files -z")
+ "find . -type f -not -regex '.*\\.gem$' -print0 \
+| sort -z | cut -zc3-")))))))
(propagated-inputs
(list ruby-addressable
ruby-mercenary
- ruby-nokogumbo
+ ruby-nokogiri
ruby-parallel
ruby-rainbow
ruby-typhoeus