summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2023-07-09 14:57:20 +0900
committerChristopher Baines <mail@cbaines.net>2023-07-10 12:39:34 +0100
commitf6e6d5981fdd38fab8cedea6f2d8460f7a0488bd (patch)
treeee2ecdc033e821040efb9fffc3e9b1c0f5257b79 /gnu/packages/ruby.scm
parent98eaf21d4aa897b9fee1d5aec4ffff4c393299cf (diff)
gnu: ruby-rbnacl: Use new package style.
* gnu/packages/ruby.scm (ruby-rbnacl): Use new package style. [arguments]: Use gexp. [source, propagated-inputs, inputs, native-inputs]: Restyle format. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm84
1 files changed, 42 insertions, 42 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9426a95f01..e47e3a01c9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3250,50 +3250,50 @@ same log file.")
(package
(name "ruby-rbnacl")
(version "7.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (rubygems-uri "rbnacl" version))
- (sha256
- (base32
- "0y8yzianlkc9w6sbqy8iy8l0yym0y6x7p5rjflkfixq76fqmhvzk"))))
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rbnacl" version))
+ (sha256
+ (base32
+ "0y8yzianlkc9w6sbqy8iy8l0yym0y6x7p5rjflkfixq76fqmhvzk"))))
(build-system ruby-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-unnecessary-dependencies
- (lambda _
- ;; Coveralls relates to a network service, and Rubocop to code
- ;; linting and both are unnecessary to run the tests
- (substitute* "Gemfile"
- ((".*rubocop.*") "\n")
- ((".*guard-rspec.*") "\n")
- ((".*coveralls.*") "\n"))
- (substitute* "spec/spec_helper.rb"
- (("require \"coveralls\"") "")
- (("Coveralls.wear!") ""))
- #t))
- (add-after 'unpack 'use-libsodium-from-store
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("lib/rbnacl/init.rb"
- "lib/rbnacl/sodium.rb")
- (("ffi_lib \\[.+\\]")
- (string-append "ffi_lib [\""
- (assoc-ref inputs "libsodium") "/lib/libsodium.so"
- "\"]")))
- #t))
- ;; Run Rspec directly to avoid the Rubocop dependency in the Rakefile
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "rspec"))
- #t)))))
- (propagated-inputs
- (list ruby-ffi))
- (inputs
- (list libsodium))
- (native-inputs
- (list bundler ruby-rspec))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-unnecessary-dependencies
+ (lambda _
+ ;; Coveralls relates to a network service, and Rubocop to code
+ ;; linting and both are unnecessary to run the tests
+ (substitute* "Gemfile"
+ ((".*rubocop.*")
+ "\n")
+ ((".*guard-rspec.*")
+ "\n")
+ ((".*coveralls.*")
+ "\n"))
+ (substitute* "spec/spec_helper.rb"
+ (("require \"coveralls\"")
+ "")
+ (("Coveralls.wear!")
+ ""))))
+ (add-after 'unpack 'use-libsodium-from-store
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("lib/rbnacl/init.rb"
+ "lib/rbnacl/sodium.rb")
+ (("ffi_lib \\[.+\\]")
+ (string-append "ffi_lib [\""
+ (assoc-ref inputs "libsodium")
+ "/lib/libsodium.so" "\"]")))))
+ ;; Run Rspec directly to avoid the Rubocop dependency in the
+ ;; Rakefile
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec")))))))
+ (propagated-inputs (list ruby-ffi))
+ (inputs (list libsodium))
+ (native-inputs (list bundler ruby-rspec))
(synopsis "Ruby FFI binding to libsodium")
(description
"This package provides Ruby FFI bindings to the Networking and