summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-29 11:53:40 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:02 +0100
commit403d721d56e4535a64b806402fab5cda1481e270 (patch)
treea66376fff56c559f6f92afcf2a1fe25678a2431a /gnu/packages/ruby.scm
parentc5d10ca52a28a57e3c026bf401d07c589ea6ba2b (diff)
gnu: ruby-net-http-persistent: Update to 4.0.2.
* gnu/packages/ruby.scm (ruby-net-http-persistent): Update to 4.0.2. [native-inputs]: Add ruby-rake-manifest.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 734930779f..02aec95712 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4322,16 +4322,18 @@ help tests uncover more bugs.")
(define-public ruby-net-http-persistent
(package
(name "ruby-net-http-persistent")
- (version "3.0.0")
+ (version "4.0.2")
(source (origin
(method url-fetch)
(uri (rubygems-uri "net-http-persistent" version))
(sha256
(base32
- "156rv95bgxfz6qw5y1r7c7bswr77918hygl8dyl14qzbqc5vyp18"))))
+ "0i1as2lgnw7b4jid0gw5glv5hnxz36nmfsbr9rmxbcap72ijgy03"))))
(build-system ruby-build-system)
(native-inputs
- (list ruby-connection-pool ruby-hoe))
+ (list ruby-connection-pool
+ ruby-hoe
+ ruby-rake-manifest))
(synopsis "Persistent HTTP connection manager")
(description "Net::HTTP::Persistent manages persistent HTTP connections
using Net::HTTP, supporting reconnection and retry according to RFC 2616.")