summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-04 16:19:54 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:26:05 +0100
commit9c164d72b2bbdb1823befb32bede82f6af431750 (patch)
treec0feaf9b991c5c331dc80b54cd8a43e2826ccebc /gnu/packages/ruby.scm
parente13dc6a024deb38c16a3989ab7cfff240b9ae2ac (diff)
gnu: ruby-safe-yaml: Fix build.
* gnu/packages/ruby.scm (ruby-safe-yaml)[arguments]: Build with #:ruby ruby-2.7 and update style.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index dbbc73b98a..bcbf433377 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -13727,17 +13727,18 @@ indentation will probably be an issue and hence this gem.")
(native-inputs
(list ruby-rspec ruby-hashie ruby-heredoc-unindent))
(arguments
- '(#:test-target "spec"
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-TZ
- (lambda _
- ;; This test is dependent on the timezone
- ;; spec/transform/to_date_spec.rb:35
- ;; # SafeYAML::Transform::ToDate converts times to the local
- ;; timezone
- (setenv "TZ" "UTC-11")
- #t)))))
+ (list
+ #:ruby ruby-2.7
+ #:test-target "spec"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-TZ
+ (lambda _
+ ;; This test is dependent on the timezone
+ ;; spec/transform/to_date_spec.rb:35
+ ;; # SafeYAML::Transform::ToDate converts times to the local
+ ;; timezone
+ (setenv "TZ" "UTC-11"))))))
(home-page "https://github.com/dtao/safe_yaml")
(synopsis "YAML parser")
(description "The SafeYAML gem provides an alternative implementation of