summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-06 16:22:07 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:42:15 +0100
commitc1c159176b748c073f59171a8fa16bfa39ce1b30 (patch)
tree440362a4e271be6b3a81e58f1eafeac4a22a3126 /gnu/packages/ruby.scm
parentde24aaf13b17d6c019f3f240fd0eb0e1b8654970 (diff)
gnu: Add ruby-test-unit-ruby-core.
* gnu/packages/ruby.scm (ruby-test-unit-ruby-core): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 59dc27e24f..34ebeebe7e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4801,6 +4802,25 @@ It allows writing tests, checking results and automated testing in Ruby.")
(list #:tests? #f)))
(native-inputs '()))))
+(define-public ruby-test-unit-ruby-core
+ (package
+ (name "ruby-test-unit-ruby-core")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "test-unit-ruby-core" version))
+ (sha256
+ (base32 "1i7fa4hlj6xiqvjaikagwrmiyc21jzyswvd4grjbfqysziwsxygc"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list #:tests? #f)) ; contains no tests
+ (synopsis "Additional test assertions for Ruby standard libraries")
+ (description "This package provides additional test assertions for Ruby
+standard libraries.")
+ (home-page "https://github.com/ruby/test-unit-ruby-core")
+ (license license:ruby)))
+
(define-public ruby-mapping
(package
(name "ruby-mapping")